Can't update 1.45.00 to 1.46.01

Post Reply
Ralf
Posts: 42
Joined: 23 Sep 2018, 18:13

Can't update 1.45.00 to 1.46.01

Post by Ralf »

Copied new 1.46.01 files on existing 1.45.00 version and Login screen shows:

Upgrading to version 1.46.00
Failed to upgrade database, please contact support@soplanning.org with full details.
upgrade failed :
1.46.00
request failed :
ALTER TABLE `planning_user` ADD `date_creation` DATETIME NOT NULL AFTER `login_actif`

:(
soplanning
Site Admin
Posts: 289
Joined: 31 Aug 2017, 15:58

Re: Can't update 1.45.00 to 1.46.01

Post by soplanning »

Hello
Can you run manually this query in phpmyadmin and let us know what is the error ?
it seems some users have the same problem, depending on their server settings.
thanks
Ralf
Posts: 42
Joined: 23 Sep 2018, 18:13

Re: Can't update 1.45.00 to 1.46.01

Post by Ralf »

ALTER TABLE `planning_user` ADD `date_creation` DATETIME NOT NULL AFTER `login_actif`

MySQL meldet:
#1292 - Falscher datetime-Wert: '0000-00-00 00:00:00' für Feld 'date_creation' in Zeile 1
soplanning
Site Admin
Posts: 289
Joined: 31 Aug 2017, 15:58

Re: Can't update 1.45.00 to 1.46.01

Post by soplanning »

can you try this please :
ALTER TABLE `planning_user` ADD `date_creation` DATETIME NOT NULL DEFAULT CURRENT_TIMESTAMP AFTER `login_actif`;
and run the rest of the sql file
Ralf
Posts: 42
Joined: 23 Sep 2018, 18:13

Re: Can't update 1.45.00 to 1.46.01

Post by Ralf »

Upgrading to version 1.46.00
Database upgrade ok for version 1.46.00
Upgrading to version 1.46.01
Database upgrade ok for version 1.46.01
:D
Merci beaucoup
Great job
Stay healthy
Post Reply